Bundesamt für Sicherheit in der Informationstechnik

CB-K18/0443

Risikostufe 4

Titel:Samba: Zwei Schwachstellen ermöglichen die Eskalation von Privilegien und einen Denial-of-Service-AngriffDatum:13.03.2018Software:Samba < 4.5.16, Samba < 4.6.14, Samba < 4.7.6Plattform:Debian Linux 8.10 Jessie, Debian Linux 9.4 Stretch, GNU/Linux, Red Hat Fedora 26, Red Hat Fedora 27Auswirkung:PrivilegieneskalationRemoteangriff:JaRisiko:hochCVE Liste:CVE-2018-1050, CVE-2018-1057Bezug: Debian Security Advisory DSA-4135-1

Beschreibung

Samba ist eine freie Software-Suite, die das Server-Message-Block-Protokoll (SMB) für Unix-Systeme verfügbar macht.

Eine Schwachstelle in Samba ermöglicht einem entfernten, einfach authentifizierten Angreifer das Ändern der Passwörter für beliebige andere Benutzer über LDAP. Der Angreifer kann dadurch auch Administratorrechte erlangen. Eine weitere Schwachstelle ermöglicht einem entfernten, nicht authentisierten Angreifer einen Denial-of-Service-Angriff auf den Drucker-Spooler über RPC. Der Hersteller stellt Samba 4.7.6, 4.6.14 und 4.5.16 als Sicherheitsupdates zur Behebung der Schwachstellen bereit. Für Fedora 26 und 27 stehen Sicherheitsupdates auf die Versionen 4.6.14 (Fedora 26) und 4.7.6 (Fedora 27) im Status 'pending' zur Verfügung. Mit dem Update für Fedora 27 wird auch eine neue Version von 'libldb' ausgeliefert. Für Debian Stretch steht ein Backport-Sicherheitsupdate bereit. Debian stellt für Debian Jessie ein Sicherheitsupdate zur Behebung der Schwachstelle CVE-2018-1050 in Aussicht, die schwerwiegende Schwachstelle CVE-2018-1057 kann aufgrund der umfangreichen zur Behebung notwendigen Änderungen für diese Distribution aber nicht mehr adressiert werden. Zur Mitigation dieser Schwachstelle wird auf den Workaround des Herstellers verwiesen.