Bundesamt für Sicherheit in der Informationstechnik

CB-K18/0221 Update 4

Risikostufe 3

Titel:mbed TLS: Merhere Schwachstellen ermöglichen die Ausführung beliebigen ProgrammcodesDatum:22.03.2018Software:mbed TLS >= 1.3.0, mbed TLS < 1.3.22, mbed TLS < 2.1.10, mbed TLS < 2.7.0, PolarSSLPlattform:SUSE Package Hub for SUSE Linux Enterprise 12, Debian Linux 8.10 Jessie, Debian Linux 9.4 Stretch, GNU/Linux, Microsoft Windows , openSUSE Leap 42.3, Red Hat Fedora 26, Red Hat Fedora 27, Extra Packages for Red Hat Enterprise Linux 6, Extra Packages for Red Hat Enterprise Linux 7Auswirkung:Ausführen beliebigen ProgrammcodesRemoteangriff:JaRisiko:mittelCVE Liste:CVE-2017-18187, CVE-2018-0487, CVE-2018-0488Bezug: mbed TLS Security Advisory 2018-01

Beschreibung

mbed TLS ist eine Bibliothek, welche SSL/TLS-Funktionen zur Verfügung stellt und zuvor den Namen PolarSSL trug.

Die C-Bibliothek PolarSSL stellt SSL- und TLS-Funktionen zur Verfügung.

Ein entfernter, nicht authentisierter Angreifer kann zwei Schwachstellen für Denial-of-Service (DoS)-Angriffe oder zur Ausführung beliebigen Programmcodes ausnutzen. Der Hersteller informiert über die Schwachstellen in mbed TLS ab Version 1.3.0 bzw. 1.3.8 und in allen Versionen des Versionszweigs 2.1, wenn die Zertifikatsauthentifizierungsmethode 'optional' verwendet wird. Die Versionen mbed TLS 1.3.22, mbed TLS 2.1.10 und mbed TLS 2.7.0 stehen als Sicherheitsupdates zur Verfügung. Als möglicher Workaround empfiehlt der Hersteller die Funktion 'MBEDTLS_PKCS1_V21' und die Verwendung von HMAC-Erweiterungen zu deaktivieren.